System Slowdown

Incident Report for Neon Fundraise

Resolved

This incident has been resolved.
Posted Mar 25, 2025 - 14:20 PDT

Monitoring

We have restarted the system, after which sites are now fully operational.
Posted Mar 25, 2025 - 11:57 PDT

Investigating

We are currently investigating this issue.
Posted Mar 25, 2025 - 09:07 PDT

Identified

We are seeing a system slowdown. We’re actively working speed things up.
Posted Mar 25, 2025 - 07:49 PDT
This incident affected: Integrations (Sprocket API), Fundraising (Donations, Registrations, Recurring Plans Processing), and Administration (Management interfaces, Site Builder, Reporting, Automation).