System Slowdown
Incident Report for Neon Fundraise
Resolved
This incident has been resolved. We will be releasing updates tonight that should prevent such incidents from recurring.
Posted Jul 02, 2024 - 13:01 PDT
Identified
We are seeing another system slowdown, related to previous ones we’ve been seeing. We’re actively working to clear up queues and queries to free up load.
Posted Jul 02, 2024 - 10:50 PDT
This incident affected: Fundraising (Donations, Registrations) and Administration (Management interfaces, Site Builder, Reporting).