Degraded performance on Registrants grid
Incident Report for Neon Fundraise
Resolved
We deployed some slight changes to the grid that has resolved the issue.
Posted Nov 21, 2023 - 10:15 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 21, 2023 - 06:36 PST
Investigating
This morning at around 7:20am Pacific, we received alerts that the Registrants grid (in the Admin, under People) was failing to load. After some research, we identified that the issue occurs specifically when sorting the grid ascending by Last Name, and that being the default sort configuration, it was failing for every load.

As such, at 12:00pm Pacific, we deployed a hotfix that changes the default sort configuration to registration date, with newest first. That way, the grid doesn't fail every time it is loaded. Still, if an administrator manually changes the sort to Last Name ascending, the grid will fail in that instance.

We are still investigating the root cause of the issue and will post an update when we have a fix.
Posted Nov 20, 2023 - 14:45 PST
This incident affected: Administration (Management interfaces).