Recurring Charges Not Running

Incident Report for Neon Fundraise

Resolved

This incident has been resolved.
Posted Apr 10, 2025 - 05:17 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 09, 2025 - 23:33 PDT

Identified

Our team discovered that recurring plan charges have not run since April 3rd due to a thread stoppage. The thread will be unblocked during tonight’s scheduled release, after which charges will resume from where they left off, so any plan that missed a charge during this period will be charged soon after the release. The team is also taking steps to prevent this from happening again in the future.
Posted Apr 09, 2025 - 11:35 PDT
This incident affected: Fundraising (Recurring Plans Processing).